Help solving IO::Error


#22

Yeah, that version actually causes some other errors. We still have to dig in to what’s going on, but for now we can’t even add it in.


#23

I’ve been experiencing this issue as well, and also haven’t found a solution. Except that sometimes running it at 10=10=10 makes it go away sometimes, but not forever.
(I’m using crystal-pg directly)


#24

I believe I’ve run into this a few times before. My hunch is that the connection to the DB is actually going through a load balancer that times out “eventually” or something like that…the DB connection pool should be handling that though :|


#25

Hello,

Just bumping here, indeed the previous version of Clear wasn’t fiber-proof and all fibers were consuming the stream of only one connection. It has been solved with adding the connection pool.

I’ve no clue about your problem here, some ideas:

  • You may want to setup PGBouncer between Postgres and your app.
  • You may want to give a look about locks on your app by calling SELECT * FROM pg_stat_activity WHERE datname = 'xxx'. Lock can easily be overlooked and can appears easily when multiple transaction happens at the same time.

About your problem with the latest release of Clear, feel free to open an issue or talk to me directly if you want ^^’ let’s try to figure out what’s going on! :+1:


#26

Thanks for the suggestions! I need to get back on this. We weren’t able to use the version with the connection pool because of another issue, but I know you fixed that recently. I’ll give this another shot and see if it’s solved now.