Problem with the digital build of Crystalline (language server). Building from source works, though! :-)

I tried to use Crystalline (language server) with VSCode on macOS, got :

dyld[3268]: Library not loaded: /usr/local/opt/llvm@14/lib/libLLVM.dylib
  Referenced from: <DF523EFC-CF38-3988-93E4-C884DD15CA5F> /Users/sergehulne/crystalline
  Reason: tried: '/usr/local/opt/llvm@14/lib/libLLVM.dylib' (no such file), '/System/Volumes/Preboot/Cryptexes/OS/usr/local/opt/llvm@14/lib/libLLVM.dylib' (no such file), '/usr/local/opt/llvm@14/lib/libLLVM.dylib' (no such file), '/usr/local/lib/libLLVM.dylib' (no such file), '/usr/lib/libLLVM.dylib' (no such file, not in dyld cache)
[Info  - 11:52:33] Connection to server got closed. Server will restart.

brew list llvm@14 | grep "ibLLVM.dylib" yields :

brew list llvm@14 | grep "ibLLVM.dylib"

you need to put libLLVM.dylib to the /usr/local/opt/llvm@14/lib folder, or the other alternative folders stated in the message.

just put them in some random folder won’t work, the binary can’t find it that way. you can try your luck with some environment variables like CRYSTAL_LIBRARY_PATH but I’m not sure it would help.

1 Like