CentOS: error unpacking rpm file


#1

Today I run

sudo yum update

to install the latest version of Crystal which would be 0.27.2-1 for this machine.
There was an error in unpacking the rpm file
the message was:

Downloading packages:
crystal-0.27.2-1.x86_64.rpm                                                                                                              |  38 MB  00:00:02
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : crystal-0.27.2-1.x86_64                                                                                                                      1/1
Error unpacking rpm package crystal-0.27.2-1.x86_64
error: unpacking of archive failed on file /usr/share/crystal/src/lib_c/amd64-unknown-openbsd: cpio: rename
  Verifying  : crystal-0.27.2-1.x86_64                                                                                                                      1/1

Failed:
  crystal.x86_64 0:0.27.2-1

Complete!

does anyone else has experienced a problem?


#2

I try a fresh install in fedora-28 and it run without problems :thinking:


#3

Does https://access.redhat.com/solutions/3419141 or http://www.sergiohenriques.com/sos/linux/yum-installupdate-errors-cpio-rename/ helps?


#4

Hi Brian,

thanks for the response.
Unfortunately none of the procedures worked for me.
this happened in a long running VM (240+ days). So I rebooted the system to make sure no rogue process has claimed a file in question.
The path in question is a directory, the examples you sent deal with files. There is no special attribute set on that directory.

if it’s of any help, the lsb_release -a output is

LSB Version:    :core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Distributor ID: CentOS
Description:    CentOS Linux release 7.6.1810 (Core)
Release:        7.6.1810
Codename:       Core

#5

Solution:

I deleted /usr/share/crystal/… which solved the problem.


#6

I hope you reinstalled it later!


#7

I thought that was obvious :-).